Raspberry Pi 3 Autoguider - Lin_Guider installieren

Beitragsseiten

3.      Lin_Guider installieren:


Um den Lin_Guider sauber zum Laufen zu bringen, müssen zuerst ein paar Libraries und das „Linux Hotplug Project“ fxload installiert werden.
Hier die Befehle:

sudo apt-get install libusb-1.0-0-dev

sudo apt-get install libqt4-dev

sudo apt-get install libftdi-dev

sudo apt-get install libxtst-dev build-essential libqt4-dev qt4-qmake

sudo apt-get install fxload
 
Falls einer der Befehle wider Erwarten mit einer Fehlermeldung abgebrochen werden sollte, folgt den Anweisungen auf der Konsole oder macht ein Update mit sudo apt-get update. Der Update-Befehl sollte aber das letzte Mittel sein, denn es kann sein, dass damit andere Geräte nicht mehr funktionieren… Mit den hier beschriebenen Programm-/Betriebssystemversionen kommt es aber zu keiner Fehlermeldung!


Als nächstes ladet ihr euch den Lin_Guider selbst herunter. Für diese Anleitung habe ich die derzeit aktuellste Version 3.2.2 verwendet und das Archiv trägt den Namen „lin_guider-3.2.2.tar.bz2“
Heruntergeladen werden kann das Programm bei Sourceforge.

wget http://downloads.sourceforge.net/project/linguider/3.2.2/lin_guider-3.2.2.tar.bz2

Sofern kein anderer Pfad angegeben wurde, landet der Download in eurem Homeverzeichnis und sollte ohne weitere Pfadangaben von einer frischen Konsole aus erreichbar sein.
Entpackt wird das Archiv linuxüblich mit:

tar -xvf lin_guider-3.2.2.tar.bz2

Anschließend in das Lin_guider-Verzeichnis wechseln

cd lin_guider_pack

cd lin_guider

Kompiliert wird das Ganze dann mit:

./configure

und

make
 
Das Kompilieren kann ein wenig dauern, ist aber deutlich schneller als bei den Vorgänger-Modellen!